slow gameplay on edgy

Bugs should be reported at
This section is read only for reference.
Joined:Sun Feb 04, 2007 10:23 pm
slow gameplay on edgy

Post by Mirkov » Sun Feb 04, 2007 10:38 pm

i've installed glob2 0.8.21 from ubuntu edgy package.

Code: Select all

glob2 -version

Globulation 2 - 0.8.21

Compiled on Sep 27 2006 at 10:45:02

Compiled with SDL version 1.2.10
Linked with SDL version 1.2.10

Featuring :
* Map version 50
* Maps up to version 23 can still be loaded
* Network Protocol version 22
* YOG Protocol version 5

This program and all related materials are GPL, see COPYING for details.
(C) 2001-2005 Stephane Magnenat, Luc-Olivier de Charriere and other contributors.
See AUTHORS for a full list.

Type glob2 --help for a list of command line options.
my hardware is athlon 64 3.2 GHz, 1GB ram, nvidia 6600gt w 128 MB vram. the game runs somewhat slow, and the red line in the upper part of the screen is always red and about 2-3 times longer than it should be @ 640x480.

should game run fine on my hw?

i've tried using both sdl and open gl, performance is the same.

i have nvidia module loaded, and have been playing true combat: elite - the game plays fine with default settings in full screen. that game is a 3d 1st person shooter, whose graphics seem slightly more complex than those of glob2.

has anyone else had similar problems, what should i check? does the game write some kind of log / debug messages - when i run if from shell, i get no usual output like from other gui apps when started from command line.

thx in advance

User avatar
Joined:Sat Nov 26, 2005 10:23 pm

Post by Giszmo » Tue Feb 06, 2007 11:47 pm

Hi Mirkov

As I have pretty much the same hw I can tell you that there should be no problem running glob2 openGL enabled with up to 1600x1200 (max value so far)

if you experience problems i bet there is one with your openGL and glob2. nevertheless it should not show a red bar if you run it at 640x480 openGL disabled, reduced grafix(, no custom cursor)

if you can't confirm that, it would be great if you could help us find the reason for glob2 to run slow on your machine.

Joined:Sun Feb 04, 2007 10:23 pm

Post by Mirkov » Wed Feb 07, 2007 12:46 am

servus ;)

thanks for the reply. it seems i was impatient: i was starting tutorial, and the red line stood for some 30 seconds or so, and i kept closing the game.

but once, i left it on, and about the time in tutorial the first inn is built, the red line became green. onwards in the tutorial i had no probs, and could also play single player mission without any problems.

i can reproduce the problem with both deb pkg from glob2 site and with ubuntu pkg. the red line phase seems to last longer if i do not press space (dismiss the tut messages).

it seems to have something to do with beggining of the tutorial or with displaying text during gameplay, which is bad because it may scare a new user away. and that would be a shame, because the game is great.

i'm a programmer in my day job, so if you need detailed desc or something, please tell.

another question: i noticed with both glob2 and true combat elite that when the game is started in full screen mode, i can not switch away from it (to window manager) with alt+tab. i suppose my config is borked, but before googling for help i just wanted to make sure that switching away from game with alt+tab should be possible?